CI 묻고 답하기

제목 version mismatch라는 오류입니다.
카테고리 일반
글쓴이 psj452 작성시각 2017/09/04 19:32:23
댓글 : 7 추천 : 0 스크랩 : 0 조회수 : 952   RSS

A PHP Error was encountered

Severity: Warning

Message: mysqli::real_connect(): Headers and client library minor version mismatch. Headers:50541 Library:50634

Filename: mysqli/mysqli_driver.php

Line Number: 201

Backtrace:

File: C:\MAMP\htdocs\application\controllers\topic.phpLine: 5Function: database

File: C:\MAMP\htdocs\index.phpLine: 315Function: require_once

object(stdClass)#20 (4) { ["id"]=> string(1) "1" ["title"]=> string(13) "JavaScript란" ["description"]=> string(691) "

 

localhost 상에서 MAMP설치하고 천천히 예제를 따라가며 공부하고있었습니다.

CMD창에서 DB도 만들고 잘하고있었는데 테이블 불러올때 위와 같은 오류가 뜨네요..

혹시 방법이 없을까요?

PHP를 지웠다가 다시 재컴파일을 하라는얘기도 있고 버전이 맞는지 확인하라고 하고 버전업을 하라는데

어떤식으로 뭘 해야할지모르는 초보입니다. ㅜ

현재 Mysql 버전은  5.6.34-log 이며

구글링 결과 Client API library version 과 Client API header version 라이브러리 버전과 헤더버전이 안맞을 경우 발생할수도 있다는데 저도 같은 현상인가요? 그리고 대부분 리눅스 환경에서 변경하여 해결하던데 저는 CMD 창에서 하는거라 저런 명령어들이 안먹네요 ㅜ

알려주시면 감사하겠습니다 !!! 

 다음글 써드파티 개념이 잘 안잡히네요.. (1)
 이전글 CI model 배열로 인스턴스를 받아올수있나요? (4)

댓글

한대승(불의회상) / 2017/09/05 08:46:13 / 추천 0
mysql 버전을 확인해 보세요.
psj452 / 2017/09/05 11:27:03 / 추천 0
버전을 확인해서 어떻게 할까요?
한대승(불의회상) / 2017/09/05 11:35:57 / 추천 0

mysql 접속하셔서 아래처럼 하시면 됩니다.

select version();

 

 

psj452 / 2017/09/05 11:43:50 / 추천 0
지금 현재 버전 5.6.34-log라고 되어있습니다!
psj452 / 2017/09/05 11:55:08 / 추천 0

Client API library version

Client API header version

구글링해보면 라이브러리 버전과 헤더버전이 안맞을 경우 발생한다는데 저도 같은 현상인가요? 그리고 대부분 리눅스 환경에서 변경하여 해결하던데 저는 CMD 창에서 하는거라 저런 명령어들이 안먹네요 ㅜ

한대승(불의회상) / 2017/09/05 12:37:15 / 추천 0
mamp 다른 버전이나 xampp 와 같은 다른 컨테이너를 설치해 보시는게 좋을것 같습니다.
psj452 / 2017/09/05 13:02:13 / 추천 0
네~!