개발 Q&A

제목 imap 설치 후 phpinfo() 찍혔는데 안됩니다..ㅜㅜ
카테고리 PHP
글쓴이 뫄뫄잉뿌 작성시각 2018/05/08 13:36:51
댓글 : 9 추천 : 0 스크랩 : 0 조회수 : 994   RSS

안녕하세요.

네이버 메일 연동하는 것 때문에 여쭤봅니다.

imap_open 함수를 이용하여 imap을 통해 네이버 메일을 가져오려고 하는데,

imap_open 함수가 정의되어있지 않다고하여 구글링해서

imap 설치, php.ini에서 extension부분에 imap 주석 해제 후 아파치 재시작해서

phpinfo(); 찍었을 때 모듈 부분에 IMAP 이 나오는 것까지 확인했는데도

imap_opne()함수가 없는 함수라고 에러가 떠서 문의드립니다.

설치랑 php에 적용은 정상적으로 된 것 같은데 왜 안될까요...ㅜㅜ

 

---------------------

php.ini에서 extension=php_imap.dll 이부분 주석 해제하고 아파치 재시작하면

Message:  PHP Startup: Unable to load dynamic library '/opt/php/lib/php/extensions/no-debug-non-zts-20131226/php_imap.dll' - /opt/php/lib/php/extensions/no-debug-non-zts-20131226/php_imap.dll: cannot open shared object file: No such file or directory

요런 에러가 납니다.

php-imap을 두번 설치했다는 소리일까요...?ㅜㅜ

 다음글 CAPTCHA 질문드립니다. (2)
 이전글 seo 최적화 프레임워크는 무엇이 있을까요? (6)

댓글

변종원(웅파) / 2018/05/08 14:42:13 / 추천 0
에러 메시지 그대로입니다. 파일이 없습니다. php_imap.dll 검색해서 해당 위치로 복사하세요.
뫄뫄잉뿌 / 2018/05/08 14:46:16 / 추천 0

@변종원(웅파)님

답변 감사합니다!

리눅스 콘솔에서 find / -name "php_imap.dll" 검색해봤는데 하나도 나오지 않네요...ㅜㅜ

설치가 비정상적으로 됐다는 걸까요..?

이제다시 / 2018/05/08 15:08:12 / 추천 0

리눅스 환경이면 .so 파일이 설치됬을 거에요

.dll 은 윈도우 확장자 입니다.

뫄뫄잉뿌 / 2018/05/08 15:36:22 / 추천 0

@이제다시님

답변 감사합니다!

find / -name "imap.so" 로 so파일 경로를 찾아서 extention=imap.so경로 해주고 apache 재시작 후 재로드 해보니

Message:  PHP Startup: imap: Unable to initialize module
Module compiled with module API=20090626
PHP    compiled with module API=20131226
These options need to match

이렇게 뜨네용...ㅠㅠㅠㅠㅠ 뭔가 옵션을 맞추라는 것 같은데...어떻게 해결해야할까요..ㅜㅜ?

변종원(웅파) / 2018/05/08 16:31:09 / 추천 0
에러 메세지를 구글번역에라도 돌려보세요. 답은 에러메세지에 다 있습니다.
뫄뫄잉뿌 / 2018/05/08 17:25:06 / 추천 0

@변종원(웅파)님

답변 감사합니다!

번역해봤는데 저 옵션을 어디서 맞춰야할지를 모르겠어서요... 번거롭게 해드려 정말 죄송합니다 ㅜㅜ

/etc/php.d/imap.ini 쪽에 extension을 직접 경로로 imap.so를 줬는데도 안돼서요ㅠㅜ

IamMonk / 2018/05/09 02:55:24 / 추천 0
아마도 해당 모듈이 현재 보유하신 php 버젼보다 버젼이 낮은 듯 합니다. 해당 php 버젼에 맞는 모듈을 다운로드 받으셔서 설치해보세요. 전 FreeBSD에서 pkg로 php와 php extension의 업데이트를 일괄적으로 해서 모듈간의 버젼 충돌은 잘 없는 편입니다만 Linux는 잘 몰라서 답변이 안된것 같지만 참고가 되시길 빕니다.
뫄뫄잉뿌 / 2018/05/09 13:13:06 / 추천 0

@IamMonk님

답변 감사합니다!

yum install php-imap으로 해서 5.3.3-49 버전으로 현재 centos6.9에서는 최신버전인데 php 버전에 따라 다른가보네요...

참고하여 구글링 해보겠습니다!

뫄뫄잉뿌 / 2018/05/09 14:15:24 / 추천 0

해결했습니다!

remi 저장소 설치, remi.repo에서 php56 활성화, yum install php-imap으로 설치하여 해결했습니다!