개발 Q&A

제목 centos, php 버전 업에 대한 질문입니다.
카테고리 서버
글쓴이 뫄뫄잉뿌 작성시각 2017/07/06 18:07:21
댓글 : 3 추천 : 0 스크랩 : 0 조회수 : 657   RSS

안녕하세요!

 

예전 서버랑 그나마 최신 서버랑 두개가 있는데 최신서버에서 작업하다가 예전 서버로 옮길일이 생겨 옮겼는데..

버전때문에 실행이 안되는 겁니다.ㅜㅜ

 

버전 확인해보니

centos 5.9에 php 5.2.16.. 

올린 프로젝트는 CI버전 3.1.5...ㅜㅠㅠㅠㅠ돌아갈리가..ㅠㅜㅠㅜㅠ

 

그래서 버전업을 해줘야하거나 ci버전을 낮춰야 할 것 같은데..

이왕하는김에 버전업쪽이 더 좋을거 같다는 개인적인 생각...?이예요.

근데 구서버에 있는 프로젝트들이 버전업하면서 먹통이 될까바 그게 제일 걱정이예요 ㅠㅠ(제일 제일 큰걱정....하)

 

근데 버전업할 때 음.. 패치작업?처럼 한단계 한단계 업해야되는건지.. 

아니면 바로 버전업시켜도 되는건지 궁금합니다.

 

아니면 그냥.. 그냥 ci버전을 낮춰서 다시할까요..? 그게 더 마음이 편할까요...ㅜㅜㅠ

 다음글 환경설정 관련 데이터의 경우 세션에 저장해서 사용하시나... (5)
 이전글 HTML 파일 캐싱에 관한 도움요청 (3)

댓글

kaido / 2017/07/06 18:37:12 / 추천 0

php 버전은 OS에 그렇게 종속적이진 않습니다.

apt 이나 yum 의 경우도 미러서버 지정을 해서 바꾸면 자동 업데이트 가능 하구요.

sentos 5.x 버전대가 제가 했을때는 yum으로 php7 이 업그레이드가 안되었습니다., [지금은 모르겠다만...]

정 안되면 직접 다운받아서 설치 하셔도 됩니다.

저도 php7 처음 나왔을때는 배타버전이라서 직접 소스로 설치했던 기억이 나네요.

 

문제는 구서버에 다른 프로젝트도 같이 들어있다면... ci 버전을 낮추는 것이 좋습니다. [2.x 버전 사용가능.]

ci는 몇가지만 바꾸면 되지만, 구 프로젝트는 어떤 폭탄이 터질지 모르니깐요.

뫄뫄잉뿌 / 2017/07/07 09:32:57 / 추천 0

@kaido님

답변 감사합니다!

ci버전을 낮추는 방향으로 다시 바꿔야겠네요.. 다시설치 들어가야겠어요! 

뫄뫄잉뿌 / 2017/07/07 10:26:07 / 추천 0
변경중인데 ion_auth사용해서 또 문제네요 ㅋㅋㅋ php 5.3버전 이하라..ㅜㅜ