만들면서 배우는 CodeIgniter Q&A

제목 만들면서 배우는 CodeIgniter 프레임워크로 공부 중 질문 드립니다.
글쓴이 kdm7173 작성시각 2016/09/20 18:23:37
댓글 : 2 추천 : 0 스크랩 : 0 조회수 : 3238   RSS

버전 관련된 문제인데요. 이 책을 사기 전에 미리 설치하고 한번 해보느라 3.0.6버전을 설치해서 공부하고 있었는데

책을 구매 한 후 버전 생각안하고 하고있었는데 에러가 뜨는 것 같아서 보니깐 버전이 다르네요..

책은 2.1.3버전이라고 되어있는데 3버전으로 하지말고 2.1.3버전으로 설치해서 하는 것이 나을까요?

 

이것도 문제고 다른 문제가 제 php 버전이 7.0.1인데 이건 괜찮은지요.

이미 진행중인 프로젝트 (코드이그나이터 안쓰고 그냥 날코딩해놓은게 한 8천줄? 정도 되는 파일이 수십개 있어서...) 때문에 php는 버전을 낮추기가 애매할 것 같고.. 대충 보니깐 그 예제 소스로 올려 두신 것 보니깐 DB_Driver가 기본으로 mysql로 되어 있는데 3.0.6버전은 mysqli로 되어 있더라구요. 근데 php7부터는 mysql 함수는 못쓰고 mysqli만 쓸 수 있다고 해서 이거 문제되지 않을까 싶기도 하고 해서 질문드립니다.. php 버전을 낮추기는 힘들 것 같고 codeigniter 버전도 안맞는 상태고 이 상태로는 올려두신 소스로 계속 진행하기는 어려울까요?

그렇다고 그냥 책보고 완전 코딩을 다시 하려니깐 오탈자 때문에.. (혹시나 2쇄가 올줄 알았는데 아니였네요ㅋ 인터넷 주문이라.) 일일히 찾아가면서 하기는 좀 애매한 상황인 것 같기도 하고. 현 상황에서 어떻게 하는게 가장 좋을까요?

일일히 오탈자 찾아가면서 코딩하면서 하는게 답일까요? 7버전이랑 충돌은 mysqli만 생각하고 DB driver만 바꾸면 되겠거니 하고 있긴한대 codeigniter 버전을 2.1.3으로 낮추어야 될 상황이다 싶으면 그건 그냥 뭐 싹 날리고 새로 받으면 될 것 같고요. 3버전으로 진행해도 딱히 문제가 없다면 그대로 진행하고싶기는 합니다. 7버전은 mysqli만 생각하면 될까요?

 다음글 4장 소스를 받아 실행시키는데요. (3)
 이전글 예제 소스를 어디서 받을 수 있나요?? (3)

댓글

변종원(웅파) / 2016/09/21 14:27:43 / 추천 0

ci 2.X 버전으로 바꾸시고 드라이버를 mysqli로만 바꿔주시면 됩니다.

ci 3 버전으로 하시려면 컨트롤러, 모델 파일명 첫자를 대문자로 해줘야 합니다. 

kdm7173 / 2016/09/21 14:42:43 / 추천 0
네 알겠습니다. 답변 감사합니다.